2019 C3 Aircross Blower not working

Faults and Technical chat for the Citroen Aircross
Post Reply
Piedyp
Posts: 2
Joined: Sun Nov 19, 2023 8:35 pm

Post by Piedyp »

Hi All

Grateful for some guidance.

We own a 2019 C3 Aircross and the blower has stopped working. We press the + and - on the screen and nothing happens. There appears to some air coming out of the vent and the temperature changes but the speed doesn't change.

Doing a bit of research it appears to either the blower resistor or the actual blower motor?Where are these located?

Citroen want £140 just to diagnose the problem and then the cost of the resistor and motor appear high, around £200 each. So, would like to pursue a non Citroen part in the first instance. Or should we bite the bullet and just go to Citroen?

Thanks!

User avatar
Juan Sheet
Posts: 1312
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet »

Most of these issues are caused by the Blower Motor Control Module. Usually it's all or nothing with regards to the fan, but can also result in no fan speed at all.

In some circumstances the damp weather and the moisture extracted from the interior can cause the bearings in the actual blower Motor to become damp and then they seize slightly. Because the blower fan spins up slowly, this can prevent the fan from getting enough power to free itself. When this happens the issue can right itself or not...

The other cause is that the actual blower motor control module has failed and needs replacing. These are about £215 including VAT at present for an original, but beware cheaper brands can either simply not work or are dead on arrival, so if going to replace it yourself get a decent branded part.

The other thing can be the air conditioning ECU itself, but I've not heard of any of these failing to date.

Hence why Citroen charge a diagnostic fee which is for up to 1 hour, as they have to determine what is likely to be the cause.

The original part is made by Mahle, and they are not much cheaper prices from £180 to £191, but a shortage of these at present.
Piedyp
Posts: 2
Joined: Sun Nov 19, 2023 8:35 pm

Post by Piedyp »

Juan - thank you.

I am thinking its this part number: 16 810 553 80

Also, do you know where it is located? and how you get to it?

Tx.
User avatar
Juan Sheet
Posts: 1312
Joined: Sat Dec 04, 2021 4:59 pm

Post by Juan Sheet »

C3AC BMCM.PNG

It's 22 on the diag.

Access via passenger footwell, you may have to remove parts of the side trim to get to the top left where it is located.

I hope you have arms like pipe cleaners....
inboxkrish999
Posts: 1
Joined: Thu Dec 28, 2023 7:24 pm

Post by inboxkrish999 »

Hello, encountered the same problem with my C3 68 Plate, despite having only covered 35k miles.

I observed this issue after the car was idle for 3 weeks during our holiday. It started working again after being used for 2 days.

@Piedyp, I've consistently relied on Citroen for service and MOT, and now they're proposing a £140 charge for diagnosis.

Thanks, @Juan, for sharing helpful pictures.

Could you please share how you resolved the issue? Thanks.
Post Reply